Office The Courseware Company cannot be reached over phone

Minor incident
2021-10-28 13:24 CET · 2 hours, 28 minutes, 16 seconds

Updates

Resolved

The problem is solved. We can be reached by phone again.

October 28, 2021 · 15:53 CET
Issue

Due to changes in the powergrid of the office of The Courseware Company, we are experiencing downtime on our office phone network. Please contact your accountmanager directly or send an e-mail to info@courseware.nl so we can call you back. We apologize for any inconvenience.

October 28, 2021 · 13:30 CET

← Back